Search

Friday, February 19, 2010

Quick and Dirty Zone-Based Firewall Config

Building configuration...

Current configuration : 1074 bytes
!
version 12.4
service timestamps log datetime msec
service timestamps debug datetime msec
no service password-encryption
!
hostname R1

ip ssh version 2
ip ssh retries 3

class-map type inspect match-any priv-allow-class
 match protocol telnet
 match protocol http
 match protocol icmp
 match protocol tcp
!
policy-map type inspect pmap
 class type inspect priv-allow-class
inspect
class type inspect class-default
!
!
!
zone security private
zone security public
zone-pair security priv-pub source private destination public
 service-policy type inspect pmap
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0/0
ip address 10.10.1.10 255.0.0.0
zone-member security private
clock rate 64000
!
interface Serial0/0/1
ip address 172.16.1.88 255.255.255.0
zone-member security public
clock rate 64000
!
ip classless
!
!
!
!
!

line con 0
line vty 0 4
login
end
R1#

No comments: